paramètres globaux dans un product

Aller en bas

paramètres globaux dans un product

Message par JulienP45 le Jeu 20 Oct 2011 - 0:22

Bonjour,

J'utilise dans la construction d'un produit des copies de la même pièce de base que je place à différents endroits dans Assembly design.
cette pièce de base comporte des paramètres dans sa conception. toutes ces copies de la pièce originale ont donc les mêmes paramètres mais une fois incorporés dans le produit, le contrôle des paramètres de l'une des pièces n'implique pas le changement des paramètres des autres copies de pièces (ce qui est assez normale puisque finalement ce sont des pièces différentes en soit). j'aimerais trouvé un moyen (par des paramètres globaux ou des publications) de pouvoir contrôler à partir du produit tous ces paramètres en meme temps, si quelqu'un connait un moyen.

Je n'arrive pas à créer par exemple un publication dans l'arbre principal du produit, seulement à l'intérieur des sous produits...

Merci d'avance pour votre aide.

Julien

JulienP45
timide
timide

Messages : 7
Date d'inscription : 14/09/2011
Localisation : Clermont-Ferrand

Revenir en haut Aller en bas

Re: paramètres globaux dans un product

Message par Threedots le Jeu 20 Oct 2011 - 1:04

Bonjour,

Tu pourrais, lors de la copie, utiliser l'option "collage spécial", et "en tant que résultat avec lien".

Cela devrait te permettre d'avoir toutes les instances qui changent en même temps.

Par contre, cela me semble bizarre, car dans un assemblage on a plus souvent du mal à dissocier deux pièces qui ont la même origine (même forme, juste une longueur qui varie), car elle se remettent à jour en même temps...
Mais soit...

Sinon, pour créer un paramètre global, active le product, et utilise la fonction "f(x)" pour créer ton paramètre.
Après, c'est peut-être une histoire d'affichage des paramètre ou pas...
Vas voir dans "outils"->"options"->"infrastructure"_>"structure du produit"->"personnalisation de l'arbre" et actives les paramètres et publications si tu le souhaites.

Dis-nous si tu résous ton problème !
avatar
Threedots
Fédérateur
Fédérateur

Messages : 617
Date d'inscription : 16/09/2010
Age : 30
Localisation : Toulouse

Revenir en haut Aller en bas

Re: paramètres globaux dans un product

Message par JulienP45 le Jeu 20 Oct 2011 - 2:38

Je n'arrive toujours pas à créer une publication d'un paramètre d'une PART d'un sous produit dans l'arborescence principal (produit principal).
j'ai l'erreur suivante qui s'affiche[img][/img][img][/img] (voir image si vous la recevez bien).
en gros CATIA me dit que j'utilise des caractères bizarre dans le nom de mon paramètre alors que le nom de mon paramètre est seulement espessor (pas de guillemet ou : ou ! ou quoi que ce soit), je ne comprens pas. mais cette erreur n'apparait lorsque je le fais au sein du sous produit et la publication se fait bien dans le sous produit.

voila

PS: il m'est impossible d'activer ou desactiver les publications dans la "personnalisation de l'arbre" contrairement au paramètre par exemple.

JulienP45
timide
timide

Messages : 7
Date d'inscription : 14/09/2011
Localisation : Clermont-Ferrand

Revenir en haut Aller en bas

Re: paramètres globaux dans un product

Message par Threedots le Jeu 20 Oct 2011 - 2:45

Oui, pour les publications, pas possible de les afficher non plus...

Concernant l'erreur : le nom de ton sous produit est bizarre lui ? Parce que la chaine de caractère c'est je pense 'Sous-produit/Part/Paramètres/Nom Paramètre' ...
Il faut éviter de mettre des espaces dans les noms (remplace par "_"), cela peut générer des problèmes...
avatar
Threedots
Fédérateur
Fédérateur

Messages : 617
Date d'inscription : 16/09/2010
Age : 30
Localisation : Toulouse

Revenir en haut Aller en bas

Re: paramètres globaux dans un product

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum