Problème affichage de paramètres dans une nomenclature

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème affichage de paramètres dans une nomenclature

Message par denat888 le Dim 21 Aoû 2016 - 20:51

Bonjour

Désolé, j'avais oublié le titre

Je viens de récupérer un projet sur Catia V5. je travaille sur des assemblages avec des parts qui n'ont pas le même template de départ.
J'ai besoin de créer une nomenclature texte (pas dans la mise en plan) avec plusieurs paramètres masse, matériau, centres de gravité.
J'arrive à avoir ces informations dans l'arbre d'assemblage grace au module inertia (calcul de masse).
Pour avoir ces informations dans la nomenclature, je crée un paramètre dans chaque part puis le lie à une formule.
Par exemple, je crée un paramètre MASSE et le lie à une formule inertia.masse
Quand je visualise ce paramètre dans la page propriété de la part, l'information est là et est exacte.
Mais quand je visualise la nomenclature de l'assemblage (éditer nomenclature ), les paramètres de certaines pièces sont absents.
Quelqu'un a t'il eu ce problème et sait il le résoudre.

Y a t'il une solution directe ou faut il passer par une macro ?
Je peux vous envoyer les fichiers : les pièces et l'assemblage Catia V5 mais je ne sais pas le faire sur le forum.

Par avance merci

JC Denat

denat888
timide
timide

Messages : 2
Date d'inscription : 24/07/2016
Localisation : Toulouse

Revenir en haut Aller en bas

Re: Problème affichage de paramètres dans une nomenclature

Message par raphael_59240 le Ven 26 Aoû 2016 - 23:29

bonjour,

Avant tous as tu changer le format? voici des snapsho
t[Vous devez être inscrit et connecté pour voir ce lien]
suite de quoi 1 tu fais le choix ds la liste et ensuite tu utilise les boutons à ta guise[Vous devez être inscrit et connecté pour voir ce lien]
voila et en theorie tu as toute les parametres inscrit.



raphael
avatar
raphael_59240
actif
actif

Messages : 123
Date d'inscription : 28/03/2015
Age : 46
Localisation : dunkerque

Revenir en haut Aller en bas

Re: Problème affichage de paramètres dans une nomenclature

Message par lumpazepfel le Mar 30 Aoû 2016 - 8:18

Bonjour Jean Claude,

Avec la fonction "Analyse" "Nomenclature" ,on ne peut exporter en fichier texte ou excel que les propriétés qui sont dans l'onglet "Produit" ; les paramètres tels que la matière et la masse ne sont à ma connaissance pas accessible.
Il faut donc par macro ou manuellement rajouter les propriétés voulues et renseigner leur valeur.
Une autre méthode consiste à exporter la nomenclature avec les propriétés existantes et ensuite par macro de rechercher pour chaque Part les paramètres voulus.
avatar
lumpazepfel
actif
actif

Messages : 143
Date d'inscription : 03/11/2015
Localisation : Ensisheim

Revenir en haut Aller en bas

Re: Problème affichage de paramètres dans une nomenclature

Message par lgesl1catia le Sam 26 Nov 2016 - 8:48

Bonsoir

Si tes informations sont des paramètres, tu peux les liés a de nouvelles propriétés
que tu vas créer
Ensuite les propriétés vont apparaître comme dans l'exemple a Raphael
Il te reste a générer la nomenclature
avatar
lgesl1catia
actif
actif

Messages : 33
Date d'inscription : 24/11/2016
Localisation : orne

Revenir en haut Aller en bas

Re: Problème affichage de paramètres dans une nomenclature

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum